configure-ptt-chedecorare-oglive-methodsejecutarscript-b64fix-cfg2objfixes-winlgromero-filebeatmainmodulesnew-browserno-ptt-paramogadmcliogadmclient-statusogagent-jobsogagent-macosogcore1oglogoglog2override-moduleping1ping2ping3ping4py3-winreport-progresstlsunification2unification3versionswindows-fixes
Last change
on this file since 833a0dc was
10fab78,
checked in by Natalia Serrano <natalia.serrano@…>, 10 months ago
|
refs #464 several fixes and improvements
- fix OG icon in windows system tray
- change a log.info into log.debug to avoid a crash (!)
- migrate update.sh to python so it can be run from windows/macos too
- manage windows/VERSION in this script too
- remove call to pyrcc--it's not required!
- remove stray windows scripts
- add a forgotten setup.bat
|
-
Property mode set to
100755
|
File size:
2.0 KB
|
Rev | Line | |
---|
[d7a7a1f] | 1 | # -*- mode: python ; coding: utf-8 -*- |
---|
| 2 | |
---|
| 3 | |
---|
| 4 | ogausr_a = Analysis( |
---|
| 5 | ['OGAgentUser.py'], |
---|
| 6 | pathex=[], |
---|
| 7 | binaries=[], |
---|
| 8 | datas=[ |
---|
| 9 | # ('cfg', 'cfg'), ## add the entire directory |
---|
[10fab78] | 10 | ('img', 'img'), ## add the entire directory |
---|
[d7a7a1f] | 11 | ], |
---|
| 12 | hiddenimports=['win32timezone', 'socketserver', 'http.server', 'urllib'], |
---|
| 13 | hookspath=[], |
---|
| 14 | hooksconfig={}, |
---|
| 15 | runtime_hooks=[], |
---|
| 16 | excludes=[], |
---|
| 17 | noarchive=False, |
---|
| 18 | optimize=0, |
---|
| 19 | ) |
---|
| 20 | ogasvc_a = Analysis( |
---|
| 21 | ['opengnsys\\windows\\OGAgentService.py'], |
---|
| 22 | pathex=[], |
---|
| 23 | binaries=[], |
---|
| 24 | datas=[], |
---|
| 25 | hiddenimports=['win32timezone', 'socketserver', 'http.server', 'urllib'], |
---|
| 26 | hookspath=[], |
---|
| 27 | hooksconfig={}, |
---|
| 28 | runtime_hooks=[], |
---|
| 29 | excludes=[], |
---|
| 30 | noarchive=False, |
---|
| 31 | optimize=0, |
---|
| 32 | ) |
---|
| 33 | |
---|
| 34 | MERGE( |
---|
| 35 | (ogausr_a, 'OGAgentUser', 'OGAgentUser'), ## class, py name, exe name |
---|
| 36 | (ogasvc_a, 'OGAgentService', 'OGAgentService') |
---|
| 37 | ) |
---|
| 38 | |
---|
| 39 | ogausr_pyz = PYZ(ogausr_a.pure) |
---|
| 40 | ogasvc_pyz = PYZ(ogasvc_a.pure) |
---|
| 41 | |
---|
| 42 | ogausr_exe = EXE( |
---|
| 43 | ogausr_pyz, |
---|
| 44 | ogausr_a.scripts, |
---|
| 45 | [], |
---|
| 46 | exclude_binaries=True, |
---|
| 47 | name='OGAgentUser', |
---|
| 48 | debug=False, |
---|
| 49 | bootloader_ignore_signals=False, |
---|
| 50 | strip=False, |
---|
| 51 | upx=True, |
---|
| 52 | console=False, |
---|
| 53 | disable_windowed_traceback=False, |
---|
| 54 | argv_emulation=False, |
---|
| 55 | target_arch=None, |
---|
| 56 | codesign_identity=None, |
---|
| 57 | entitlements_file=None, |
---|
| 58 | icon=['img\\oga.ico'], |
---|
| 59 | ) |
---|
| 60 | ogasvc_exe = EXE( |
---|
| 61 | ogasvc_pyz, |
---|
| 62 | ogasvc_a.scripts, |
---|
| 63 | [], |
---|
| 64 | exclude_binaries=True, |
---|
| 65 | name='OGAgentService', |
---|
| 66 | debug=False, |
---|
| 67 | bootloader_ignore_signals=False, |
---|
| 68 | strip=False, |
---|
| 69 | upx=True, |
---|
| 70 | console=True, |
---|
| 71 | disable_windowed_traceback=False, |
---|
| 72 | argv_emulation=False, |
---|
| 73 | target_arch=None, |
---|
| 74 | codesign_identity=None, |
---|
| 75 | entitlements_file=None, |
---|
| 76 | icon=['img\\oga.ico'], |
---|
| 77 | manifest='OGAgent.manifest', |
---|
| 78 | ) |
---|
| 79 | |
---|
| 80 | dist_name = 'OGAgent' |
---|
| 81 | coll = COLLECT( |
---|
| 82 | ogausr_exe, |
---|
| 83 | ogausr_a.binaries, |
---|
| 84 | ogausr_a.datas, |
---|
| 85 | |
---|
| 86 | ogasvc_exe, |
---|
| 87 | ogasvc_a.binaries, |
---|
| 88 | ogasvc_a.datas, |
---|
| 89 | |
---|
| 90 | strip=False, |
---|
| 91 | upx=True, |
---|
| 92 | upx_exclude=[], |
---|
| 93 | name=dist_name, |
---|
| 94 | ) |
---|
| 95 | |
---|
| 96 | import shutil |
---|
| 97 | shutil.copytree ('cfg', '{}/{}/cfg'.format(DISTPATH, dist_name)) |
---|
Note: See
TracBrowser
for help on using the repository browser.