source: ogAgent-Git/src/OGAgent.spec @ d7a7a1f

configure-ptt-chedecorare-oglive-methodsejecutarscript-b64fix-cfg2objfixes-winlgromero-filebeatmainmodulesnew-browserno-ptt-paramogadmcliogadmclient-statusogagent-jobsogagent-macosogcore1oglogoglog2override-moduleping1ping2ping3ping4py3-winreport-progresstlsunification2unification3versionswindows-fixes
Last change on this file since d7a7a1f was d7a7a1f, checked in by Natalia Serrano <natalia.serrano@…>, 10 months ago

refs #309 #393 #408 build and package ogagent py3/qt6 for windows

  • Property mode set to 100755
File size: 2.0 KB
Line 
1# -*- mode: python ; coding: utf-8 -*-
2
3
4ogausr_a = Analysis(
5    ['OGAgentUser.py'],
6    pathex=[],
7    binaries=[],
8    datas=[
9#        ('cfg', 'cfg'),      ## add the entire directory
10    ],
11    hiddenimports=['win32timezone', 'socketserver', 'http.server', 'urllib'],
12    hookspath=[],
13    hooksconfig={},
14    runtime_hooks=[],
15    excludes=[],
16    noarchive=False,
17    optimize=0,
18)
19ogasvc_a = Analysis(
20    ['opengnsys\\windows\\OGAgentService.py'],
21    pathex=[],
22    binaries=[],
23    datas=[],
24    hiddenimports=['win32timezone', 'socketserver', 'http.server', 'urllib'],
25    hookspath=[],
26    hooksconfig={},
27    runtime_hooks=[],
28    excludes=[],
29    noarchive=False,
30    optimize=0,
31)
32
33MERGE(
34    (ogausr_a, 'OGAgentUser',    'OGAgentUser'),        ## class, py name, exe name
35    (ogasvc_a, 'OGAgentService', 'OGAgentService')
36)
37
38ogausr_pyz = PYZ(ogausr_a.pure)
39ogasvc_pyz = PYZ(ogasvc_a.pure)
40
41ogausr_exe = EXE(
42    ogausr_pyz,
43    ogausr_a.scripts,
44    [],
45    exclude_binaries=True,
46    name='OGAgentUser',
47    debug=False,
48    bootloader_ignore_signals=False,
49    strip=False,
50    upx=True,
51    console=False,
52    disable_windowed_traceback=False,
53    argv_emulation=False,
54    target_arch=None,
55    codesign_identity=None,
56    entitlements_file=None,
57    icon=['img\\oga.ico'],
58)
59ogasvc_exe = EXE(
60    ogasvc_pyz,
61    ogasvc_a.scripts,
62    [],
63    exclude_binaries=True,
64    name='OGAgentService',
65    debug=False,
66    bootloader_ignore_signals=False,
67    strip=False,
68    upx=True,
69    console=True,
70    disable_windowed_traceback=False,
71    argv_emulation=False,
72    target_arch=None,
73    codesign_identity=None,
74    entitlements_file=None,
75    icon=['img\\oga.ico'],
76    manifest='OGAgent.manifest',
77)
78
79dist_name = 'OGAgent'
80coll = COLLECT(
81    ogausr_exe,
82    ogausr_a.binaries,
83    ogausr_a.datas,
84
85    ogasvc_exe,
86    ogasvc_a.binaries,
87    ogasvc_a.datas,
88
89    strip=False,
90    upx=True,
91    upx_exclude=[],
92    name=dist_name,
93)
94
95import shutil
96shutil.copytree ('cfg', '{}/{}/cfg'.format(DISTPATH, dist_name))
Note: See TracBrowser for help on using the repository browser.