1 | # norootforbuild |
---|
2 | |
---|
3 | %define libname libqtermwidget0 |
---|
4 | |
---|
5 | Name: qtermwidget |
---|
6 | Summary: Qt4 terminal widget |
---|
7 | Version: 0.2.0 |
---|
8 | Release: 1 |
---|
9 | License: GPL |
---|
10 | Source: %{name}-%{version}.tar.bz2 |
---|
11 | Group: Utility |
---|
12 | URL: https://github.com/qterminal |
---|
13 | Vendor: petr@yarpen.cz |
---|
14 | |
---|
15 | |
---|
16 | %if 0%{?fedora_version} |
---|
17 | %define breq qt4-devel |
---|
18 | %define pref %{buildroot}/usr |
---|
19 | %endif |
---|
20 | %if 0%{?mandriva_version} |
---|
21 | %define breq libqt4-devel |
---|
22 | %define pref %{buildroot}/usr |
---|
23 | %endif |
---|
24 | %if 0%{?suse_version} |
---|
25 | %define breq libqt4-devel |
---|
26 | %define pref %{_prefix} |
---|
27 | %endif |
---|
28 | |
---|
29 | |
---|
30 | BuildRequires: gcc-c++, %{breq}, cmake |
---|
31 | BuildRoot: %{_tmppath}/%{name}-%{version}-build |
---|
32 | Prefix: %{_prefix} |
---|
33 | |
---|
34 | %description |
---|
35 | QTermWidget is an opensource project based on KDE4 Konsole application. The main goal of this project is to provide unicode-enabled, embeddable QT4 widget for using as a built-in console (or terminal emulation widget). |
---|
36 | Of course I`m aware about embedding abilities of original Konsole, but once I had Qt without KDE, and it was a serious problem. I decided not to rely on a chance. I could not find any interesting related project, so I had to write it. |
---|
37 | The original Konsole`s code was rewritten entirely with QT4 only; also I have to include in the project some parts of code from kde core library. All code dealing with user interface parts and session management was removed (maybe later I bring it back somehow), and the result is quite useful, I suppose. |
---|
38 | This library was compiled and tested on three linux systems, based on 2.4.32, 2.6.20, 2.6.23 kernels, x86 and amd64. There is also a sample application provided for quick start. |
---|
39 | |
---|
40 | %package -n %{libname} |
---|
41 | Summary: Qt4 terminal widget - base package |
---|
42 | Group: "Development/Libraries/C and C++" |
---|
43 | %description -n %{libname} |
---|
44 | QTermWidget is an opensource project based on KDE4 Konsole application. |
---|
45 | The main goal of this project is to provide unicode-enabled, embeddable |
---|
46 | QT4 widget for using as a built-in console (or terminal emulation widget). |
---|
47 | |
---|
48 | %package devel |
---|
49 | Summary: Qt4 terminal widget - development package |
---|
50 | Group: "Development/Libraries/C and C++" |
---|
51 | Requires: %{libname} |
---|
52 | %description devel |
---|
53 | Development package for QTermWidget. Contains headers and dev-libs. |
---|
54 | |
---|
55 | %prep |
---|
56 | %setup |
---|
57 | |
---|
58 | %build |
---|
59 | cmake \ |
---|
60 | -DCMAKE_C_FLAGS="%{optflags}" \ |
---|
61 | -DCMAKE_CXX_FLAGS="%{optflags}" \ |
---|
62 | -DCMAKE_BUILD_TYPE=Debug \ |
---|
63 | -DCMAKE_INSTALL_PREFIX=%{pref} \ |
---|
64 | %{_builddir}/%{name}-%{version} |
---|
65 | |
---|
66 | %{__make} %{?jobs:-j%jobs} |
---|
67 | |
---|
68 | |
---|
69 | %install |
---|
70 | %makeinstall |
---|
71 | |
---|
72 | |
---|
73 | %clean |
---|
74 | %{__rm} -rf %{buildroot} |
---|
75 | |
---|
76 | %post -n %{libname} |
---|
77 | ldconfig |
---|
78 | |
---|
79 | %postun -n %{libname} |
---|
80 | ldconfig |
---|
81 | |
---|
82 | %files -n %{libname} |
---|
83 | %defattr(-,root,root,-) |
---|
84 | %doc AUTHORS LICENSE Changelog INSTALL README |
---|
85 | %{_libdir}/lib%{name}.so.%{version} |
---|
86 | %{_datadir}/%{name} |
---|
87 | %{_datadir}/%{name}/* |
---|
88 | |
---|
89 | %files devel |
---|
90 | %defattr(-,root,root,-) |
---|
91 | %{_includedir}/*.h |
---|
92 | %{_libdir}/*.so |
---|
93 | %{_libdir}/*.so.0 |
---|
94 | |
---|
95 | %changelog |
---|
96 | * Mon Oct 29 2010 Petr Vanek <petr@scribus.info> 0.2 |
---|
97 | - version bump, cmake builds |
---|
98 | |
---|
99 | * Sat Jul 26 2008 TI_Eugene <ti.eugene@gmail.com> 0.100 |
---|
100 | - Initial build |
---|