1 | %define _topdir %(echo $PWD)/rpm |
---|
2 | %define name ogagent |
---|
3 | %define version 0.0.0 |
---|
4 | %define release 1 |
---|
5 | %define buildroot %{_topdir}/%{name}-%{version}-%{release}-root |
---|
6 | |
---|
7 | BuildRoot: %{buildroot} |
---|
8 | Name: %{name} |
---|
9 | Version: %{version} |
---|
10 | Release: %{release} |
---|
11 | Summary: OpenGnsys Agent for Operating Systems |
---|
12 | License: BSD3 |
---|
13 | Group: Admin |
---|
14 | Requires: chkconfig initscripts libXScrnSaver python3-distro python3-qt5 python3-requests python3-six |
---|
15 | Vendor: OpenGnsys Project |
---|
16 | URL: https://opengnsys.es/ |
---|
17 | Provides: ogagent |
---|
18 | |
---|
19 | %define _rpmdir ../ |
---|
20 | %define _rpmfilename %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm |
---|
21 | |
---|
22 | |
---|
23 | %install |
---|
24 | curdir=`pwd` |
---|
25 | cd ../.. |
---|
26 | make DESTDIR=$RPM_BUILD_ROOT DISTRO=rh install-ogagent |
---|
27 | cd $curdir |
---|
28 | |
---|
29 | %clean |
---|
30 | rm -rf $RPM_BUILD_ROOT |
---|
31 | curdir=`pwd` |
---|
32 | cd ../.. |
---|
33 | make DESTDIR=$RPM_BUILD_ROOT DISTRO=rh clean |
---|
34 | cd $curdir |
---|
35 | |
---|
36 | |
---|
37 | %post |
---|
38 | systemctl enable ogagent.service > /dev/null 2>&1 |
---|
39 | |
---|
40 | %preun |
---|
41 | systemctl disable ogagent.service > /dev/null 2>&1 |
---|
42 | systemctl stop ogagent.service > /dev/null 2>&1 |
---|
43 | |
---|
44 | %postun |
---|
45 | # $1 == 0 on uninstall, == 1 on upgrade for preun and postun (just a reminder for me... :) ) |
---|
46 | if [ $1 -eq 0 ]; then |
---|
47 | rm -rf /etc/ogagent |
---|
48 | rm /var/log/ogagent.log |
---|
49 | fi |
---|
50 | # And, posibly, the .pyc leaved behind on /usr/share/OGAgent |
---|
51 | rm -rf /usr/share/OGAgent > /dev/null 2>&1 |
---|
52 | |
---|
53 | %description |
---|
54 | This package provides the required components to allow this machine to work on an environment managed by OpenGnsys. |
---|
55 | |
---|
56 | %files |
---|
57 | %defattr(-,root,root) |
---|
58 | /etc/ogagent |
---|
59 | /etc/xdg/autostart/OGAgentTool.desktop |
---|
60 | /etc/init.d/ogagent |
---|
61 | /usr/bin/OGAgentTool-startup |
---|
62 | /usr/bin/ogagent |
---|
63 | /usr/bin/OGAgentTool |
---|
64 | /usr/share/OGAgent/* |
---|
65 | /usr/share/autostart/OGAgentTool.desktop |
---|
66 | |
---|
67 | %changelog |
---|
68 | * Mon May 04 2020 Ramón M. Gómez <ramongomez@us.es> - 1.2.0 |
---|
69 | - Python 3 and Qt 5 compatibility |
---|
70 | |
---|
71 | * Fri Feb 07 2020 Ramón M. Gómez <ramongomez@us.es> - 1.1.1b-1 |
---|
72 | - Use python-distro to detect the distribution version |
---|
73 | |
---|
74 | * Thu May 23 2019 Ramón M. Gómez <ramongomez@us.es> - 1.1.1-1 |
---|
75 | - Set connection timeout |
---|
76 | - Compatibility with "Exam Mode" from the University of Seville |
---|
77 | |
---|
78 | * Wed May 22 2019 Ramón M. Gómez <ramongomez@us.es> - 1.1.0a-1 |
---|
79 | - Fix a bug when activating the agent with some network devices |
---|
80 | |
---|
81 | * Tue Oct 13 2016 Ramón M. Gómez <ramongomez@us.es> - 1.1.0-1 |
---|
82 | - Functional OpenGnsys Agent interacting with OpenGnsys Server 1.1.0 |
---|
83 | |
---|
84 | * Tue Jul 18 2015 Adolfo Gómez García <agomez@virtualcable.es> - 1.0.0-1 |
---|
85 | - Initial release for OpenGnsys Agent |
---|
86 | |
---|