configure-ptt-chedecorare-oglive-methodsejecutarscript-b64fix-cfg2objfixes-winlgromero-filebeatmainmodulesnew-browserno-ptt-paramogadmcliogadmclient-statusogagent-jobsogagent-macosogcore1ogliveoglogoglog2override-moduleping1ping2ping3ping4py3-winpython3qndtestreport-progresstlsunification2unification3versionswindows-fixes
Last change
on this file since eeb5b08 was
6357619,
checked in by Ramón M. Gómez <ramongomez@…>, 5 years ago
|
#940: Replace obsolete function platform.linux_distribution with distro.os_release_attr .
|
-
Property mode set to
100644
|
File size:
1.5 KB
|
Rev | Line | |
---|
[11f7a07] | 1 | %define _topdir %(echo $PWD)/rpm |
---|
| 2 | %define name ogagent |
---|
| 3 | %define version 0.0.0 |
---|
| 4 | %define release 1 |
---|
| 5 | %define buildroot %{_topdir}/%{name}-%{version}-%{release}-root |
---|
| 6 | |
---|
| 7 | BuildRoot: %{buildroot} |
---|
| 8 | Name: %{name} |
---|
| 9 | Version: %{version} |
---|
| 10 | Release: %{release} |
---|
[d3dd7cf] | 11 | Summary: OpenGnsys Agent for Operating Systems |
---|
[11f7a07] | 12 | License: BSD3 |
---|
| 13 | Group: Admin |
---|
[6357619] | 14 | Requires: chkconfig initscripts python-six python-requests python-distro PyQt4 libXScrnSaver |
---|
[9bfb4ee] | 15 | Vendor: OpenGnsys Project |
---|
[d3dd7cf] | 16 | URL: https://opengnsys.es/ |
---|
[11f7a07] | 17 | Provides: ogagent |
---|
| 18 | |
---|
| 19 | %define _rpmdir ../ |
---|
| 20 | %define _rpmfilename %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm |
---|
| 21 | |
---|
| 22 | |
---|
| 23 | %install |
---|
| 24 | curdir=`pwd` |
---|
| 25 | cd ../.. |
---|
| 26 | make DESTDIR=$RPM_BUILD_ROOT DISTRO=rh install-ogagent |
---|
| 27 | cd $curdir |
---|
| 28 | |
---|
| 29 | %clean |
---|
| 30 | rm -rf $RPM_BUILD_ROOT |
---|
| 31 | curdir=`pwd` |
---|
| 32 | cd ../.. |
---|
| 33 | make DESTDIR=$RPM_BUILD_ROOT DISTRO=rh clean |
---|
| 34 | cd $curdir |
---|
| 35 | |
---|
| 36 | |
---|
| 37 | %post |
---|
| 38 | systemctl enable ogagent.service > /dev/null 2>&1 |
---|
| 39 | |
---|
| 40 | %preun |
---|
| 41 | systemctl disable ogagent.service > /dev/null 2>&1 |
---|
| 42 | systemctl stop ogagent.service > /dev/null 2>&1 |
---|
| 43 | |
---|
| 44 | %postun |
---|
| 45 | # $1 == 0 on uninstall, == 1 on upgrade for preun and postun (just a reminder for me... :) ) |
---|
| 46 | if [ $1 -eq 0 ]; then |
---|
| 47 | rm -rf /etc/ogagent |
---|
| 48 | rm /var/log/ogagent.log |
---|
| 49 | fi |
---|
[9bfb4ee] | 50 | # And, posibly, the .pyc leaved behind on /usr/share/OGAgent |
---|
[11f7a07] | 51 | rm -rf /usr/share/OGAgent > /dev/null 2>&1 |
---|
| 52 | |
---|
| 53 | %description |
---|
[9bfb4ee] | 54 | This package provides the required components to allow this machine to work on an environment managed by OpenGnsys. |
---|
[11f7a07] | 55 | |
---|
| 56 | %files |
---|
| 57 | %defattr(-,root,root) |
---|
| 58 | /etc/ogagent |
---|
| 59 | /etc/xdg/autostart/OGAgentTool.desktop |
---|
| 60 | /etc/init.d/ogagent |
---|
| 61 | /usr/bin/OGAgentTool-startup |
---|
| 62 | /usr/bin/ogagent |
---|
| 63 | /usr/bin/OGAgentTool |
---|
| 64 | /usr/share/OGAgent/* |
---|
| 65 | /usr/share/autostart/OGAgentTool.desktop |
---|
Note: See
TracBrowser
for help on using the repository browser.