source: ogAgent-Git/linux/debian/rules

tls
Last change on this file was dd82e4d, checked in by Natalia Serrano <natalia.serrano@…>, 6 months ago

refs #1106 remove vim swapfile from the deb packages

  • Property mode set to 100755
File size: 886 bytes
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3configure: configure-stamp
4configure-stamp:
5        dh_testdir
6        touch configure-stamp
7build: build-arch build-indep
8build-arch: build-stamp
9build-indep: build-stamp
10build-stamp: configure-stamp
11        dh_testdir
12        $(MAKE)
13        touch $@
14clean:
15        dh_testdir
16        dh_testroot
17        rm -f build-stamp configure-stamp
18        dh_clean
19install: build
20        dh_testdir
21        dh_testroot
22        dh_prep
23        dh_installdirs
24        $(MAKE) DESTDIR=$(CURDIR)/debian/ogagent install-ogagent
25        find $(CURDIR) -name '*.swp' -exec rm -f '{}' ';'
26binary-arch: build install
27        # emptyness
28binary-indep: build install
29        dh_testdir
30        dh_testroot
31        dh_installchangelogs
32        dh_installdocs
33        dh_installdebconf
34        dh_installinit --no-start
35        dh_python3=python
36        dh_compress
37        dh_link
38        dh_fixperms
39        dh_installdeb
40        dh_shlibdeps
41        dh_gencontrol
42        dh_md5sums
43        dh_builddeb
44binary: binary-indep
45.PHONY: build clean binary-indep binary install configure
Note: See TracBrowser for help on using the repository browser.