[42bd667] | 1 | # -*- mode: python -*-
|
---|
| 2 |
|
---|
| 3 | block_cipher = None
|
---|
| 4 |
|
---|
| 5 |
|
---|
| 6 | a = Analysis(['web2py.py'],
|
---|
| 7 | pathex=['.'],
|
---|
| 8 | binaries=[],
|
---|
| 9 | datas=[],
|
---|
| 10 | hiddenimports=['site-packages', 'cgi', 'cgitb', 'code', 'concurrent', 'concurrent.futures',
|
---|
| 11 | 'concurrent.futures._base', 'concurrent.futures.process', 'concurrent.futures.thread', 'configparser', 'csv', 'ctypes.wintypes',
|
---|
| 12 | 'email.mime', 'email.mime.base', 'email.mime.multipart', 'email.mime.nonmultipart', 'email.mime.text', 'html.parser', 'http.cookies',
|
---|
| 13 | 'ipaddress', 'imp', 'json', 'json.decoder', 'json.encoder', 'json.scanner', 'logging.config', 'logging.handlers', 'profile', 'pstats',
|
---|
| 14 | 'psycopg2', 'psycopg2._ipaddress', 'psycopg2._json', 'psycopg2._range', 'psycopg2.extensions', 'psycopg2.extras', 'psycopg2.sql',
|
---|
| 15 | 'psycopg2.tz', 'pyodbc', 'python-ldap', 'rlcompleter', 'sched', 'site', 'smtplib', 'sqlite3', 'sqlite3.dbapi2', 'sqlite3.dump', 'timeit', 'tkinter',
|
---|
| 16 | 'tkinter.commondialog', 'tkinter.constants', 'tkinter.messagebox', 'uuid', 'win32con', 'win32evtlogutil', 'winerror', 'wsgiref',
|
---|
| 17 | 'wsgiref.handlers', 'wsgiref.headers', 'wsgiref.simple_server', 'wsgiref.util', 'xml.dom', 'xml.dom.NodeFilter', 'xml.dom.domreg',
|
---|
| 18 | 'xml.dom.expatbuilder', 'xml.dom.minicompat', 'xml.dom.minidom', 'xml.dom.pulldom', 'xml.dom.xmlbuilder', 'xmlrpc.server'],
|
---|
| 19 | hookspath=[],
|
---|
| 20 | runtime_hooks=[],
|
---|
| 21 | excludes=['gluon'],
|
---|
| 22 | win_no_prefer_redirects=False,
|
---|
| 23 | win_private_assemblies=False,
|
---|
| 24 | cipher=block_cipher,
|
---|
| 25 | noarchive=False)
|
---|
| 26 | pyz = PYZ(a.pure, a.zipped_data,
|
---|
| 27 | cipher=block_cipher)
|
---|
| 28 | exe = EXE(pyz,
|
---|
| 29 | a.scripts,
|
---|
| 30 | [],
|
---|
| 31 | exclude_binaries=True,
|
---|
| 32 | name='web2py_no_console',
|
---|
| 33 | debug=False,
|
---|
| 34 | bootloader_ignore_signals=False,
|
---|
| 35 | strip=False,
|
---|
| 36 | upx=True,
|
---|
| 37 | console=False , icon='extras\\icons\\web2py.ico')
|
---|
| 38 | coll = COLLECT(exe,
|
---|
| 39 | a.binaries,
|
---|
| 40 | a.zipfiles,
|
---|
| 41 | a.datas,
|
---|
| 42 | strip=False,
|
---|
| 43 | upx=True,
|
---|
| 44 | name='web2py_no_console')
|
---|