source: OpenRLabs-Git/deploy/rlabs-docker/web2py-rlabs/extras/build_web2py/web2py.mac.spec

main
Last change on this file was 42bd667, checked in by David Fuertes <dfuertes@…>, 4 years ago

Historial Limpio

  • Property mode set to 100755
File size: 2.5 KB
Line 
1# -*- mode: python -*-
2
3block_cipher = None
4
5
6a = Analysis(['web2py.py'],
7             pathex=['.'],
8             binaries=[('/System/Library/Frameworks/Tk.framework/Tk', 'tk'), ('/System/Library/Frameworks/Tcl.framework/Tcl', 'tcl')],
9             datas=[],
10             hiddenimports=['site-packages', 'cgi', 'cgitb', 'code', 'concurrent', 'concurrent.futures',
11              'concurrent.futures._base', 'concurrent.futures.process', 'concurrent.futures.thread', 'configparser', 'cProfile', 'csv', 'ctypes.wintypes',
12              'email.mime', 'email.mime.base', 'email.mime.multipart', 'email.mime.nonmultipart', 'email.mime.text', 'html.parser', 'http.cookies',
13              'ipaddress', 'imaplib', 'imp', 'json', 'json.decoder', 'json.encoder', 'json.scanner', 'logging.config', 'logging.handlers', 'profile', 'pstats',
14              'psycopg2', 'psycopg2._ipaddress', 'psycopg2._json', 'psycopg2._range', 'psycopg2.extensions', 'psycopg2.extras', 'psycopg2.sql',
15              'psycopg2.tz', 'pyodbc', 'python-ldap', 'rlcompleter', 'sched', 'site', 'smtplib', 'sqlite3', 'sqlite3.dbapi2', 'sqlite3.dump', 'timeit', 'tkinter',
16              'tkinter.commondialog', 'tkinter.constants', 'tkinter.messagebox', 'uuid', 'win32evtlogutil', 'wsgiref',
17              'wsgiref.handlers', 'wsgiref.headers', 'wsgiref.simple_server', 'wsgiref.util', 'xml.dom', 'xml.dom.NodeFilter', 'xml.dom.domreg',
18              'xml.dom.expatbuilder', 'xml.dom.minicompat', 'xml.dom.minidom', 'xml.dom.pulldom', 'xml.dom.xmlbuilder', 'xmlrpc.server'],
19             hookspath=[],
20             runtime_hooks=[],
21             excludes=['gluon'],
22             win_no_prefer_redirects=False,
23             win_private_assemblies=False,
24             cipher=block_cipher,
25             noarchive=False)
26pyz = PYZ(a.pure, a.zipped_data,
27             cipher=block_cipher)
28exe = EXE(pyz,
29          a.scripts,
30          [],
31          exclude_binaries=True,
32          name='web2py',
33          debug=False,
34          bootloader_ignore_signals=False,
35          strip=False,
36          upx=True,
37          console=False,
38          icon='extras/icons/web2py.icns')
39coll = COLLECT(exe,
40               a.binaries,
41               a.zipfiles,
42               a.datas,
43               strip=False,
44               upx=True,
45               name='web2py')
46app = BUNDLE(coll,
47             name='web2py.app',
48             icon='extras/icons/web2py.icns',
49             bundle_identifier=None,
50             info_plist={
51            'NSPrincipleClass': 'NSApplication',
52            'NSAppleScriptEnabled': False})
Note: See TracBrowser for help on using the repository browser.